General D.I.Y. - Do It Yourself All General D.I.Y.'s , walk throughs, tips & tricks go here.

G38 gearbox speed sensor issue!

Old 12-12-2013, 04:52 AM
  #1  
Audi Forum - Posts like an A1
Thread Starter
 
Join Date: Dec 2013
Location: Denmark
Posts: 1
DanskAudi is on a distinguished road
Default G38 gearbox speed sensor issue!

Please help!!!!

Our car

Car: Audi 80
Year: 1995
Model: Avant (Station Car)
Engine: 1Z motor 1.9 TDI
Gearbox: CLF 4 speed automatic

Donor Car

Car: Audi 80
Year: 1994
Model: Saloon
Engine: 1Z motor 1.9 TDI
Gearbox: AEG 4 speed Automatic

One of the oil cooler pipes taking oil from the gearbox to the cooler sprang a leak due to rust draining the gearbox of oil. After fixing the problem with the pipe we refilled the gearbox and it has worked for six months until last week. I tried to find a matching CLF Auto gearbox but did not succeed and a new or reconditioned one was way too expensive. So I bought a donor Audi 80 TDI from 1994 with a AEG Auto gearbox because the are the same ratios.

However, after fitting the gearbox I now have no 'gearbox speed sensor' because there was no sensor on the AEG box while there was one on my CLF box. Due to not having a reading from the gearbox speed sensor my Avant is in continuous 'Limp' mode. The 'gearbox speed sensor' code is G38 which is located on the center left top of the gearbox. There's another sensor 'G68' which is the car speed sensor.

I think I have three options to try and get it to work.

1. Try to find a bypass for the G38 gearbox speed sensor to that the car will drive normally, is this possible, can it be bypasses? What I don't understand is how it worked in the 1994 Audi without this sensor?

2. Swap the complete wire harness and ECU from the 1994 to the 1995. I have tried this!!!!! However, the car would not start and I'm assuming it's because to two wires from the 1994 harness that didn't have anywhere to connect to on my 1995 car. I'll attach a picture of the two wires, one is a heavy wire that's black and grey and the other is light and is brown and black. Any ideas?????

3. I could remove the AEG box from the car (not so easy!) dismantle both gearboxes, and transfer the guts from the AEG box to the CLF housing which would give me a unit with a gearbox speed sensor! That's assuming that the parts are interchangeable?

What to do, any ideas, has anyone had or hear of this problem before?

Please HELP!
DanskAudi is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
IloveTTs
MK1 Audi TT - 1998–2006
1
10-22-2014 07:23 PM
ryanv256
A4-B6 - (Typ 8E/8H, 2001–2005)
16
12-05-2011 08:20 PM
biglip
A4-B6 - (Typ 8E/8H, 2001–2005)
10
01-08-2011 03:24 PM
lskA4
A4-B8 - (Typ 8K, 2008–present)
0
11-28-2010 07:10 PM
Interious
Audi Mailing List
3
11-23-2003 08:57 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: G38 gearbox speed sensor issue!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.