Notices

Idle higher than expected code and then this noise

Old 01-12-2013, 09:07 AM
  #1  
Audi Forum - Posts like an A1
Thread Starter
 
Join Date: Jan 2012
Location: Sutton/Quebec/Canada
Posts: 48
Dinky_B6 is on a distinguished road
Default Idle higher than expected code and then this noise

Got a CEL on....code coming out is P0507....I'm still trying to figure out where the leak is. But now, when the engine is hot and that the idle gets higher than expected(from 1100 to 1200 rpm) this noise shows up...stops when I rev it.



I'd gladly appreciate your help!

Thx
Attached Thumbnails Idle higher than expected code and then this noise-th_strangenoise_zps8bc63749.jpg   Idle higher than expected code and then this noise-th_strangenoise_zps8bc63749.jpg  

Last edited by Dinky_B6; 01-12-2013 at 09:09 AM.
Dinky_B6 is offline  
Old 01-15-2013, 10:49 AM
  #2  
Audi Forum - Posts like an S4
 
Tim$2's Avatar
 
Join Date: Nov 2010
Location: Calgary, Alberta
Posts: 207
Tim$2 is on a distinguished road
Default Re: Idle higher than expected code and then this noise

Start by checking for vac leaks or blocked pcv valve.
Tim$2 is offline  
Old 01-15-2013, 11:05 AM
  #3  
Audi Forum - Posts like an A1
Thread Starter
 
Join Date: Jan 2012
Location: Sutton/Quebec/Canada
Posts: 48
Dinky_B6 is on a distinguished road
Default Re: Idle higher than expected code and then this noise

PCV valve is new...just changed it and yeah I'll plug the leak tester this weekend and keep you updated
Dinky_B6 is offline  
Old 01-25-2013, 07:36 AM
  #4  
Audi Forum - Posts like an A1
Thread Starter
 
Join Date: Jan 2012
Location: Sutton/Quebec/Canada
Posts: 48
Dinky_B6 is on a distinguished road
Default Re: Idle higher than expected code and then this noise

Update** Found out there was a leak in the turbo inlet pipe, i've temporarily fixed it and will replace it with a Forge unit. The whistling noise doesn't come from the rear end, so I don't think it could be the fuel pump nor filter. The noise only appears once the car is hot and also it disapears when I step on the throttle, it isn't speed related since its not increasing as the rpm goes up. I've looked at a thread talking about the PS issues in cold weather, which I'll check out tomorrow.

Any more ideas would be welcome. Oh and also when I've scanned it, the code P0171 system too lean bank 1 comes up now and the P0507 disapearred. The idle doesnt go higher than 1000rpm now but still should be at 800rpm.
Dinky_B6 is offline  
Old 02-27-2013, 04:03 PM
  #5  
Audi Forum - Posts like an A1
Thread Starter
 
Join Date: Jan 2012
Location: Sutton/Quebec/Canada
Posts: 48
Dinky_B6 is on a distinguished road
Default Re: Idle higher than expected code and then this noise

Just an update. it was the T valve under the intake manifold
Dinky_B6 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TonyKiz
Audi Mailing List
16
08-08-2007 04:14 PM
Audi Mailing List
28
08-03-2007 10:43 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Idle higher than expected code and then this noise


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.